Speeding up Lightroom

Restart Lightroom

Refreshing memory in your computer by restarting Lightroom is the first thing to try, and relieves many slow-downs.

Update to the most recent version of Lightroom

To update Lightroom, choose Help > Check For Updates in Lightroom.

Hardware

RAM: 2 GB is the minimum system requirement. But 16 GB can improve performance considerably, especially if you use other applications at the same time, like Photoshop.

SSD drives: If you have a solid-state drive, Lightroom is faster if you put your catalog (the .lrcat file) and image previews (the .lrdata file) on the SSD drive.

Moving your catalog

The default location for your catalog is in the My Pictures > Lightroom folder (Windows), or Pictures > Lightroom folder (Mac OS). Your image preview file ([catalog name Previews.lrdata]) is in the same location as your catalog. You can move your catalog and previews file to any location. However, if you do, make sure you can remember the name and location of the catalog and the previews file.

After you move your catalog, point Lightroom to its new location. When you reopen Lightroom, you're asked to locate your catalog. Select Choose a Different Catalog:


Next, the Select Catalog dialog box appears. Select your catalog. If your moved catalog is not listed, select Choose a Different Catalog. Then, navigate to the new location in the Finder window that opens.


If the dialog box below opens, select Choose a Different Catalog until the Finder window opens. Navigate to the new location of your current catalog.


If you use Photoshop with Lightroom, check Photoshop's RAM setting

See the Max Out on RAM and Memory Usage sections in this TechNote to determine the best RAM settings for your computer. To change your memory settings in Photoshop, choose Apple > Preferences > Performance (Mac OS) or Edit > Preferences > Performance (Windows).

High-resolution displays

Drawing to the screen can be slow when Lightroom is using the entire screen of a high-resolution display. A high-resolution display has a native resolution near 2560 x 1600, and is found on 30-inch monitors and Retina MacBooks. To increase performance on such displays, reduce the size of the Lightroom window, or use the 1:2 or 1:3 views in the Navigator panel.

Spot Removal tool, local corrections, and History panel

The Spot Removal Tool and Local Corrections Brush are not designed for hundreds to thousands of corrections. If your image contains many (hundreds) of localized adjustments, consider using a pixel-based editing application such as Photoshop for that level of correction.

If you have many corrections, check your History panel. The History panel has no limits, and it isn't deleted unless specified. If you've been creating many local or spot corrections, your history could be long, which can slow Lightroom's performance as a whole.

Clear the History panel by clicking the X on the right of the History panel header.

Order of Develop operations

The best order of Develop operations to increase performance is as follows:

  1. Spot healing.
  2. Geometry corrections, such as Lens Correction profiles and Manual corrections, including keystone corrections using the Vertical slider.
  3. Global non-detail corrections, such as Exposure and White Balance. These corrections can also be done first if desired.
  4. Local corrections, such as Gradient Filter and Adjustment Brush strokes.
  5. Detail corrections, such as Noise Reduction and Sharpening.

Note: Performing spot healing first improves the accuracy of the spot healing, and ensures the boundaries of the healed areas match the spot location.

Avoid corrections that you don't need

This suggestion applies especially to local corrections. Each slider you've changed when applying local corrections or the gradient filter is applied to that entire correction. And, each option uses resources and can affect performance.

When applying local corrections and gradients, make sure that you need all the corrections you've selected.

If you do not need a brush stroke or gradient to perform a certain type of correction, set its slider to zero.

Also avoid using unnecessary global corrections, especially options that use resources, such as Noise Reduction, Sharpening, and Lens Corrections.

Some sliders default to a value that turns them on by default. For the more resource-intensive options, zero does disable the slider.

Zoom options

If the Fit and Fill zoom options are slow, try using the 1:2, 1:3, or 1:4 options in the Navigator panel.

Increase the Camera Raw cache

Increasing the Camera Raw cache in Lightroom's preferences can help performance in the Develop module if you repeatedly work on the same set of images.

To reset the Camera Raw cache:

  1. In Lightroom, select Edit > Preferences > File Handling (Windows) or Lightroom > Preferences > File Handling (Mac OS).
  2. Increase the Camera Raw cache. If you're not sure how much to increase it, start with 2-3 GB initially, depending on the amount of space on your hard disk, and how you use Lightroom.
  3. You can also change the location of the cache if you want.

Use Process Version 2010?

Process Version 2012 does take more resources than Process Version 2010, so in some cases it could be slower. However, it's necessary to balance the performance gain with the editing and image quality available with Process Version 2012.

Update your video driver

Updated display drivers can fix many issues, such as crashing, incorrectly rendered objects, and performance problems.

To update the display driver on Windows 7 or Vista, see this TechNote.

On Mac OS, most video driver updates are installed with OS updates. However, Nvidia does provide some drivers. For Nvidia video cards, go to the Nvidia website.

(Via Lightroom Help: Performance hints)


Powered by Zendesk